Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 08, 2024 - 10:45 AEDT
Scheduled
We have identified a bug as a result of a minor release last night. We are going to take the system down briefly to fix, sometime in the next hour. Sorry for the inconvenience.
Posted Nov 08, 2024 - 10:28 AEDT
This scheduled maintenance affected: Front end systems (Self Service, Leave, Timesheets, Online Forms, Interactive Payslips).